  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.southernminn.com/content/tncms/live/" />
<meta name="keywords" content="" />
<meta name="news_keywords" content="" />
<meta name="description" content="ATLANTA (AP) &mdash; It would&rsquo;ve been a magnificent weekend." />
<meta name="author" content="PAUL NEWBERRY AP Sports Columnist" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="egMftXC0TUvESC79-b7wcoEfnQ16jpj897rHMmht1Yg" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/ccf30c42-2648-11e5-b4b0-afdfa9085526.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Remembering Final Four that never was" />
<meta property="og:description" content="ATLANTA (AP) &mdash; It would&rsquo;ve been a magnificent weekend." />
<meta property="og:site_name" content="Southernminn.com" />
<meta property="fb:app_id" content="226792370750450" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.c93c91680003c101b619d7dc5ab460f0.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:400,700|Raleway:300,400&amp;display=swap"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.93ba289b1a2aa847633520d7a43d11ed.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.162.0"},"page":{"grid":"centerpiece","style":"default","path":"\/","syndicated":"false","reaction":"true","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"PAUL NEWBERRY\nAP Sports Columnist","id":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e","app":"editorial"},"infinity_scroll":{"display":"summary_sticky_siderail","order":"next"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":276},"client":{"is_bot":"yes","is_gdpr":"no"},"google":{"ua":"UA-162610273-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.caf244e2614d000b4f73058e1c610d12.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.36770bdfae09a8898776cd45ffd261f5.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/southernminn.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            
                gptAdSlots['ad-864720'] = googletag.defineSlot(adUnit, [[2, 1], [1, 1]], 'ad-864720').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864720'].setTargeting('pos', ['impact-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320, 50], [3,1]]).addSize([768, 0], [[728, 90], [320,50], [3,1]]).addSize([992, 0], [[970, 90], [728, 90], [970, 250], [3,1]]).addSize([1200, 0], [[1170, 90],[970, 90], [728, 90], [970, 250], [3,1]]).build();
                gptAdSlots['ad-864711'] = googletag.defineSlot(adUnit, [[320,50],[3,1],[728,90],[970,90],[970,250],[1170,90]], 'ad-864711').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864711'].setTargeting('pos', ['breakout-one']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"button_size":"btn-lg","button_style":"danger","button_text":"Contribute","button_url":"\/contribute","card_shape":"rounded_rectangle","content_text":"Now, more than ever, the world needs trustworthy reporting\u2014but good journalism isn\u2019t free. Please support us by making a contribution.","content_text_color":"light","content_text_shadow":"enabled","display_again":"24","display_timer":"1","display_triggers":"visitor_enter","headline_shadow":"enabled","headline_size":"large","headline_text":"Support local journalism","headline_text_color":"light","image":{},"image_display":"background","overlay_action":"centered","utm_campaign_name":"contribute","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","enable_email":"","require_user_account":"","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","show_audience":"","hide_audience":"","block_id":"891911"}); /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.waypoints.1115c65bd62165d952fac7c1b6918b2a.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320, 50]]).addSize([768, 0], [[300, 250], [320, 50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-864713'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-864713').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864713'].setTargeting('pos', ['rectangle-one']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300, 250]).addSize([768, 0], [300, 250]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-864716'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-864716').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864716'].setTargeting('pos', ['rectangle-two']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            var mapping = googletag.sizeMapping().addSize([320, 0], [300, 250]).addSize([768, 0], [300, 250]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-864719'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-864719').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864719'].setTargeting('pos', ['rectangle-three']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,600], [300, 250]]).addSize([1200, 0], [[300,600], [300, 250]]).build();
                gptAdSlots['ad-864687'] = googletag.defineSlot(adUnit, [[300,600],[300,250]], 'ad-864687').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864687'].setTargeting('pos', ['sticky-side-rail']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            
                gptAdSlots['ad-864693'] = googletag.defineSlot(adUnit, [1, 1], 'ad-864693').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864693'].setTargeting('pos', ['impact-bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/southernminn.com';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320,50]]).addSize([992, 0], [[728, 90],[970,90]]).addSize([1200, 0], [[728,90], [970, 90], [1170,90]]).build();
                gptAdSlots['ad-864731'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[1170,90]], 'ad-864731').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-864731'].setTargeting('pos', ['sticky-anchor']);
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Remembering Final Four that never was |  | southernminn.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #fff; } .fixed-nav #main-navigation { background-color: #fff !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #ffffff; color: #888; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: ; } .navbar-toggle .icon-bar { background-color: !important; } .navbar-toggle .sr-only-show { color: !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #444; }@media (min-width: 1200px) { .container { width: 100%; } } @media (min-width: 1396px) { .container.has-wallpaper, .has-wallpaper .container, .container { width: 1366px; } } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: ; } }#site-copyright a, #site-footer a { color: #336699; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #a0cc39; }#site-header-container{ border-bottom: 3px solid #a0cc39; }#site-footer-container{ border-top: 3px solid #a0cc39; } .tnt-bg-accent { background-color: #a0cc39; } a .tnt-caret-down { color: #a0cc39; } .block-title .block-title-inner { border-color: #a0cc39; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #a0cc39; } .form-control:focus { border-bottom-color: #a0cc39; } /* CSS has moved to Site templates/Global skins/flexsystem-faribault/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/ccef3d2e-2648-11e5-b4af-8b20001f705c.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    <link rel="alternate" type="application/rss+xml" title="Remembering Final Four that never was |  | southernminn.com" href="http://www.southernminn.com/search/?f=rss&amp;t=article&amp;c=&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" />
            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            <script type="text/javascript">
        $(function(){
            $('.asset .share-container.content-below ul .save-asset-to-list').before("<li class='social-share-link'><a class='print-btn-added' href='javascript:window.print()' title='Print'><i class='fa fa-print'></i></a></li>");
        });
    </script>
    
    
    
    

        </head>
        <body class="fixed-scroll-nav app-editorial grid-centerpiece blox-asset uuid-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e type-article infinity-summary-sticky-siderail" data-path="/">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.southernminn.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.162.0&tncms.page.grid=centerpiece&tncms.page.style=default&tncms.page.path=%2F&tncms.page.syndicated=false&tncms.page.reaction=true&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=PAUL+NEWBERRY%0AAP+Sports+Columnist&tncms.asset.id=0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e&tncms.asset.app=editorial&tncms.infinity_scroll.display=summary_sticky_siderail&tncms.infinity_scroll.order=next&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.system.render_time=276&tncms.client.is_bot=yes&tncms.client.is_gdpr=no&tncms.google.ua=UA-162610273-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container">

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-865476" class="tncms-block in-drawer"><div id="site-logo-865476" class="site-logo-container text-center" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/eb117624-4933-11ea-a39f-c30a75fea806.jpg" 
            srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/eb117624-4933-11ea-a39f-c30a75fea806.jpg"
            sizes="100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div><div id="tncms-block-864729" class="tncms-block hidden-md hidden-lg"><section id="block-864729" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-864729" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-864729" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-864729-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-864729-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-864729-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-864729').submit();
        return false;
    });

    $('#site-search-864729').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-864729 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-864729 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-864729-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-864730" class="tncms-block hidden-lg hidden-md in-drawer"><div id="user-controls-864730" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.southernminn.com/users/login/?referer_url=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.southernminn.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-864730').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.southernminn.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.southernminn.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.southernminn.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-864730').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.southernminn.com/users/logout/" id="user-logout-form-864730"><input type="hidden" name="referer_url" value="https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-nav-mobile-nav-left-below" class="tncms-region-nav"><div id="mobile-nav-left-below_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-1" data-target="#mobile-nav-left-below_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-publications">Publications</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/faribault_daily_news/"  class="nav-link tnt-section-faribault-daily-news">Faribault Daily News</a>
                                </li><li>
                                    <a href="http://www.southernminngirlfriends.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-girlfriends-magazine">Girlfriends Magazine</a>
                                </li><li>
                                    <a href="/janesville_argus/"  class="nav-link tnt-section-janesville-argus">Janesville Argus</a>
                                </li><li>
                                    <a href="/le_sueur_county_news/"  class="nav-link tnt-section-le-sueur-county-news">Le Sueur County News</a>
                                </li><li>
                                    <a href="/lonsdale_area_news_review/"  class="nav-link tnt-section-lonsdale-area-news-review">Lonsdale Area News Review</a>
                                </li><li>
                                    <a href="/northfield_news/"  class="nav-link tnt-section-northfield-news">Northfield News</a>
                                </li><li>
                                    <a href="/owatonna_peoples_press/"  class="nav-link tnt-section-owatonna-peoples-press">Owatonna Peoples Press</a>
                                </li><li>
                                    <a href="http://southernmnscene.com"  target="_blank" rel="noopener" class="nav-link tnt-section-scene">Scene</a>
                                </li><li>
                                    <a href="/st_peter_herald/"  class="nav-link tnt-section-st-peter-herald">St. Peter Herald</a>
                                </li><li>
                                    <a href="/the_kenyon_leader/"  class="nav-link tnt-section-the-kenyon-leader">The Kenyon Leader</a>
                                </li><li>
                                    <a href="/waseca_county_news/"  class="nav-link tnt-section-waseca-county-news">Waseca County News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-2" data-target="#mobile-nav-left-below_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="https://www.mnpublicnotice.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-legal-advertisements">Legal advertisements</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="http://marketplace.southernminn.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-local-ads">Local Ads</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/subscription_options/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-5" data-target="#mobile-nav-left-below_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-e-editions">E-Editions</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/eedition/faribault/"  class="nav-link tnt-section-faribault-daily-news">Faribault Daily News</a>
                                </li><li>
                                    <a href="/eedition/faribaultshopper/"  class="nav-link tnt-section-faribault-shopper">Faribault Shopper</a>
                                </li><li>
                                    <a href="/eedition/scene/"  class="nav-link tnt-section-scene">Scene</a>
                                </li><li>
                                    <a href="/eedition/girlfriends/"  class="nav-link tnt-section-girlfriends-magazine">Girlfriends Magazine</a>
                                </li><li>
                                    <a href="/eedition/janesville/"  class="nav-link tnt-section-janesville-argus">Janesville Argus</a>
                                </li><li>
                                    <a href="/eedition/lesueur/"  class="nav-link tnt-section-le-sueur-county-news">Le Sueur County News</a>
                                </li><li>
                                    <a href="/eedition/valleyshopper/"  class="nav-link tnt-section-valley-shopper">Valley Shopper</a>
                                </li><li>
                                    <a href="/eedition/lonsdale/"  class="nav-link tnt-section-lonsdale-news-review">Lonsdale News Review</a>
                                </li><li>
                                    <a href="/eedition/northfield/"  class="nav-link tnt-section-northfield-news">Northfield News</a>
                                </li><li>
                                    <a href="/eedition/northfield_weekender/"  class="nav-link tnt-section-northfield-weekender">Northfield Weekender</a>
                                </li><li>
                                    <a href="/eedition/nugget/"  class="nav-link tnt-section-golden-nugget">Golden Nugget</a>
                                </li><li>
                                    <a href="/eedition/owatonna/"  class="nav-link tnt-section-owatonna-peoples-press">Owatonna Peoples Press</a>
                                </li><li>
                                    <a href="/eedition/owatonnashopper/"  class="nav-link tnt-section-owatonna-shopper">Owatonna Shopper</a>
                                </li><li>
                                    <a href="/eedition/stpeter/"  class="nav-link tnt-section-st-peter-herald">St. Peter Herald</a>
                                </li><li>
                                    <a href="/eedition/kenyon/"  class="nav-link tnt-section-the-kenyon-leader">The Kenyon Leader</a>
                                </li><li>
                                    <a href="/eedition/waseca/"  class="nav-link tnt-section-waseca-county-news">Waseca County News</a>
                                </li><li>
                                    <a href="/eedition/wasecashopper/"  class="nav-link tnt-section-waseca-shopper">Waseca Shopper</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-6" data-target="#mobile-nav-left-below_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-forms">Forms</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="https://southernmn.classifiedshub.biz/southernminnmedia/FlashActivation.html#"  target="_blank" rel="noopener" class="nav-link tnt-section-bargain-hunter-ad-form">Bargain Hunter Ad Form</a>
                                </li><li>
                                    <a href="https://southernmn.classifiedshub.biz/southernminnmedia/FlashActivation.html#"  target="_blank" rel="noopener" class="nav-link tnt-section-classified-ad">Classified Ad</a>
                                </li><li>
                                    <a href="https://southernmn.classifiedshub.biz/southernminnmedia/FlashActivation.html#"  target="_blank" rel="noopener" class="nav-link tnt-section-super-savers-ad-form">Super Savers Ad Form</a>
                                </li><li>
                                    <a href="/faribault_daily_news/forms/"  class="nav-link tnt-section-faribault-forms">Faribault Forms</a>
                                </li><li>
                                    <a href="/janesville_argus/forms/"  class="nav-link tnt-section-janesville-forms">Janesville Forms</a>
                                </li><li>
                                    <a href="/le_sueur_county_news/forms/"  class="nav-link tnt-section-le-sueur-county-forms">Le Sueur County Forms</a>
                                </li><li>
                                    <a href="/lonsdale_area_news_review/forms/"  class="nav-link tnt-section-lonsdale-forms">Lonsdale Forms</a>
                                </li><li>
                                    <a href="/northfield_news/forms/"  class="nav-link tnt-section-northfield-forms">Northfield Forms</a>
                                </li><li>
                                    <a href="/owatonna_peoples_press/forms/"  class="nav-link tnt-section-owatonna-forms">Owatonna Forms</a>
                                </li><li>
                                    <a href="/st_peter_herald/forms/"  class="nav-link tnt-section-st-peter-forms">St. Peter Forms</a>
                                </li><li>
                                    <a href="/the_kenyon_leader/forms/"  class="nav-link tnt-section-kenyon-forms">Kenyon Forms</a>
                                </li><li>
                                    <a href="/waseca_county_news/forms/"  class="nav-link tnt-section-waseca-forms">Waseca Forms</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-7" data-target="#mobile-nav-left-below_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/contest/"  class="nav-link tnt-section-contests">Contests</a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="http://www.southernminnscene.com/category/best-of-scene-2019-vote/#//"  target="_blank" rel="noopener" class="nav-link tnt-section-best-of-scene-2019">Best of Scene 2019</a>
                                </li></ul></div></div></div>
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-864720" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864720" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864720');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-878035" class="tncms-block"><div class="container">
<ul class="nav nav-tabs"><li class="active"><a href="/"><i class="fa tnt-home"></i> Home</a>
                    </li>
                    <li class="active"><a href="/faribault_daily_news" target="_blank">                  
                        Faribault</a>
                    </li>
                    <li class="active"><a href="/owatonna_peoples_press/" target="_blank">                  
                        Owatonna</a>
                    </li>
                    <li class="active"><a href="/northfield_news/" target="_blank">                  
                        Northfield</a>
                    </li>
                    <li class="active"><a href="/waseca_county_news/" target="_blank">                  
                       Waseca Co.</a>
                    </li>
                    <li class="active"><a href="/st_peter_herald/" target="_blank">                  
                        St. Peter</a>
                    </li>
                    <li class="active"><a href="/le_sueur_county_news/" target="_blank">                  
                        Le Sueur Co.</a>
                    </li> 
                    <li class="active"><a href="/lonsdale_area_news_review/" target="_blank">                  
                        Lonsdale</a>
                    </li>
                    <li class="active"><a href="/the_kenyon_leader/" target="_blank">                  
                       Kenyon</a>
                    </li>
                   <li class="active"><a href="/covid-19/" target="_blank" style="color:#b5140f;">                  
                       COVID-19</a>
                    </li>
                </ul></div></div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-864725" class="tncms-block padding-top"><div id="weather-864725" class="weather-current size-large pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions ">
            <a href="/weather/?weather_zip=55021" class="dropdown-toggle" >
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-cloudy"></span>
                </span>
                <span class="pull-left temp-desc large">
                    <span class="temp">28&deg;</span>
                    
                        <span class="cond">Cloudy </span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-864727" class="tncms-block"><div id="site-logo-864727" class="site-logo-container text-center" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/e96d45a2-484b-11ea-a39f-637e173ac235.jpg?resize=200%2C25" 
            srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/e96d45a2-484b-11ea-a39f-637e173ac235.jpg?resize=200%2C25 200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/e96d45a2-484b-11ea-a39f-637e173ac235.jpg?resize=300%2C38 300w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/e96d45a2-484b-11ea-a39f-637e173ac235.jpg?resize=400%2C50 400w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/e96d45a2-484b-11ea-a39f-637e173ac235.jpg 540w"
            sizes="(min-width: 1200px) 380px, 33.33vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"><div class="logo-date">
                Friday, April 3, 2020
            </div>
        <ul class="list-inline block-links pos-bottom ">
            
                
                    <li><a href="/eedition" class="">Print Edition</a></li>
                
            
            
        </ul></div>
    </div></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-865474" class="tncms-block"><div class="block header-promo pull-right">
<div class="header-promo-head">Become a Member</div>
<div class="header-promo-text"><a href="/subscription_options/">Subscribe Today</a></div>
</div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
    <div class="row equal-height masthead-promo"><div id="tncms-region-masthead-promo-a" class="tncms-region col-md-3 left-col"><div id="tncms-block-876281" class="tncms-block solo-promo"><section id="block-876281" class="block emphasis-h3    tnt-no-margin-bottom" >
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-876281-0d6db607-9b85-5478-ac29-9513f1cd44e5" class="clearfix card summary has-image image-left inherit  tnt-section-owatonna-peoples-press tnt-sub-section-news">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-0d6db607-9b85-5478-ac29-9513f1cd44e5 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/owatonna_peoples_press/news/article_0d6db607-9b85-5478-ac29-9513f1cd44e5.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Veterinarians continue to care for animals during COVID-19 restrictions"
                            class="img-responsive lazyload full default"
                            width="1400"
                            height="788"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/0/d6/0d6db607-9b85-5478-ac29-9513f1cd44e5/5e87acf75272e.preview.jpg?crop=1400%2C788%2C0%2C112&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/0/d6/0d6db607-9b85-5478-ac29-9513f1cd44e5/5e87acf75272e.preview.jpg?crop=1400%2C788%2C0%2C112&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/0/d6/0d6db607-9b85-5478-ac29-9513f1cd44e5/5e87acf75272e.preview.jpg?crop=1400%2C788%2C0%2C112&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/0/d6/0d6db607-9b85-5478-ac29-9513f1cd44e5/5e87acf75272e.preview.jpg?crop=1400%2C788%2C0%2C112&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/0/d6/0d6db607-9b85-5478-ac29-9513f1cd44e5/5e87acf75272e.preview.jpg?crop=1400%2C788%2C0%2C112&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/0/d6/0d6db607-9b85-5478-ac29-9513f1cd44e5/5e87acf75272e.preview.jpg?crop=1400%2C788%2C0%2C112&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/0/d6/0d6db607-9b85-5478-ac29-9513f1cd44e5/5e87acf75272e.preview.jpg?crop=1400%2C788%2C0%2C112&resize=1400%2C788&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/owatonna_peoples_press/news/article_0d6db607-9b85-5478-ac29-9513f1cd44e5.html" class="tnt-asset-link">
        

        
            Veterinarians continue to care for animals during COVID-19 restrictions</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div><div id="tncms-region-masthead-promo-b" class="tncms-region col-md-3 middle-col-left"><div id="tncms-block-876282" class="tncms-block solo-promo"><section id="block-876282" class="block emphasis-h3    tnt-no-margin-bottom" >
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-876282-eefe04fa-ead0-5b01-9801-f3379086c050" class="clearfix card summary has-image image-left inherit  tnt-section-faribault-daily-news tnt-sub-section-news">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-eefe04fa-ead0-5b01-9801-f3379086c050 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/faribault_daily_news/news/article_eefe04fa-ead0-5b01-9801-f3379086c050.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="Veterinarians continue to care for animals during COVID-19 restrictions"
                            class="img-responsive lazyload full default"
                            width="1400"
                            height="788"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/e/ef/eefe04fa-ead0-5b01-9801-f3379086c050/5e87b4b30aea6.preview.jpg?crop=1400%2C788%2C0%2C112&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/e/ef/eefe04fa-ead0-5b01-9801-f3379086c050/5e87b4b30aea6.preview.jpg?crop=1400%2C788%2C0%2C112&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/e/ef/eefe04fa-ead0-5b01-9801-f3379086c050/5e87b4b30aea6.preview.jpg?crop=1400%2C788%2C0%2C112&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/e/ef/eefe04fa-ead0-5b01-9801-f3379086c050/5e87b4b30aea6.preview.jpg?crop=1400%2C788%2C0%2C112&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/e/ef/eefe04fa-ead0-5b01-9801-f3379086c050/5e87b4b30aea6.preview.jpg?crop=1400%2C788%2C0%2C112&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/e/ef/eefe04fa-ead0-5b01-9801-f3379086c050/5e87b4b30aea6.preview.jpg?crop=1400%2C788%2C0%2C112&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/e/ef/eefe04fa-ead0-5b01-9801-f3379086c050/5e87b4b30aea6.preview.jpg?crop=1400%2C788%2C0%2C112&resize=1400%2C788&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/faribault_daily_news/news/article_eefe04fa-ead0-5b01-9801-f3379086c050.html" class="tnt-asset-link">
        

        
            Veterinarians continue to care for animals during COVID-19 restrictions</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div><div id="tncms-region-masthead-promo-c" class="tncms-region col-md-3 middle-col-right"><div id="tncms-block-876280" class="tncms-block solo-promo"><section id="block-876280" class="block emphasis-h3    tnt-no-margin-bottom" >
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-876280-b7bb20ac-cb33-575b-af2e-0fa2db38a290" class="clearfix card summary has-image image-left inherit  tnt-section-faribault-daily-news tnt-sub-section-news">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-b7bb20ac-cb33-575b-af2e-0fa2db38a290 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/faribault_daily_news/news/article_b7bb20ac-cb33-575b-af2e-0fa2db38a290.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="VIDEO:  Local leaders say 'Stay home, just for the health of it'"
                            class="img-responsive lazyload full default"
                            width="834"
                            height="469"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/b/7b/b7bb20ac-cb33-575b-af2e-0fa2db38a290/5e87c3eec75a9.preview.png?crop=834%2C469%2C0%2C50&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/b/7b/b7bb20ac-cb33-575b-af2e-0fa2db38a290/5e87c3eec75a9.preview.png?crop=834%2C469%2C0%2C50&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/b/7b/b7bb20ac-cb33-575b-af2e-0fa2db38a290/5e87c3eec75a9.preview.png?crop=834%2C469%2C0%2C50&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/b/7b/b7bb20ac-cb33-575b-af2e-0fa2db38a290/5e87c3eec75a9.preview.png?crop=834%2C469%2C0%2C50&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/b/7b/b7bb20ac-cb33-575b-af2e-0fa2db38a290/5e87c3eec75a9.preview.png?crop=834%2C469%2C0%2C50&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/b/7b/b7bb20ac-cb33-575b-af2e-0fa2db38a290/5e87c3eec75a9.preview.png?crop=834%2C469%2C0%2C50&resize=834%2C469&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/faribault_daily_news/news/article_b7bb20ac-cb33-575b-af2e-0fa2db38a290.html" class="tnt-asset-link">
        

        
            VIDEO:  Local leaders say 'Stay home, just for the health of it'</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div><div id="tncms-region-masthead-promo-d" class="tncms-region col-md-3 right-col"><div id="tncms-block-876283" class="tncms-block solo-promo"><section id="block-876283" class="block emphasis-h3    tnt-no-margin-bottom" >
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-876283-68047db1-8954-5624-8719-0dc35a827d6a" class="clearfix card summary has-image image-left inherit  tnt-section-owatonna-peoples-press tnt-sub-section-news">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-68047db1-8954-5624-8719-0dc35a827d6a media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/owatonna_peoples_press/news/article_68047db1-8954-5624-8719-0dc35a827d6a.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                            alt="With customers clamoring for the outdoors, greenhouse throws open its doors"
                            class="img-responsive lazyload full default"
                            width="1764"
                            height="992"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/6/80/68047db1-8954-5624-8719-0dc35a827d6a/5e8661d2f19d5.preview.jpg?crop=1764%2C992%2C0%2C91&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/6/80/68047db1-8954-5624-8719-0dc35a827d6a/5e8661d2f19d5.preview.jpg?crop=1764%2C992%2C0%2C91&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/6/80/68047db1-8954-5624-8719-0dc35a827d6a/5e8661d2f19d5.preview.jpg?crop=1764%2C992%2C0%2C91&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/6/80/68047db1-8954-5624-8719-0dc35a827d6a/5e8661d2f19d5.preview.jpg?crop=1764%2C992%2C0%2C91&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/6/80/68047db1-8954-5624-8719-0dc35a827d6a/5e8661d2f19d5.preview.jpg?crop=1764%2C992%2C0%2C91&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/6/80/68047db1-8954-5624-8719-0dc35a827d6a/5e8661d2f19d5.preview.jpg?crop=1764%2C992%2C0%2C91&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/assets/v3/editorial/6/80/68047db1-8954-5624-8719-0dc35a827d6a/5e8661d2f19d5.preview.jpg?crop=1764%2C992%2C0%2C91&resize=1700%2C956&order=crop%2Cresize 1700w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/owatonna_peoples_press/news/article_68047db1-8954-5624-8719-0dc35a827d6a.html" class="tnt-asset-link">
        

        
            With customers clamoring for the outdoors, greenhouse throws open its doors</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div></div>  

            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-864721" class="tncms-block"><div id="site-logo-864721" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/0127a336-484c-11ea-a39f-d37d6fcc37a8.jpg" 
            srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/0127a336-484c-11ea-a39f-d37d6fcc37a8.jpg"
            sizes="100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-864724" class="tncms-block sticky-nav"><div id="user-controls-864724" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a class="btn btn-block btn-primary" href="https://www.southernminn.com/users/login/?referer_url=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.southernminn.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.southernminn.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.southernminn.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-864724').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.southernminn.com/users/logout/" id="user-logout-form-864724"><input type="hidden" name="referer_url" value="https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-864723" class="tncms-block"><div id="user-controls-864723" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.southernminn.com/users/login/?referer_url=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.southernminn.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-864723').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.southernminn.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.southernminn.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.southernminn.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-864723').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.southernminn.com/users/logout/" id="user-logout-form-864723"><input type="hidden" name="referer_url" value="https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-864722" class="tncms-block"><ul id="site-search-864722-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-864722" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-864722-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-864722-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-864722-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-864722').submit();
        return false;
    });

    $('#site-search-864722').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-864722 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-864722 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-864722-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home  tnt-section-home"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe"  href="/subscription_options/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-local-ads"  href="http://marketplace.southernminn.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Local Ads</span>
                </a></li><li>
                <a class="nav-link  tnt-section-girlfriends-magazine"  href="http://www.southernminngirlfriends.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Girlfriends Magazine</span>
                </a></li><li>
                <a class="nav-link  tnt-section-scene"  href="http://southernmnscene.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Scene</span>
                </a></li><li>
                <a class="nav-link  tnt-section-covid-19"  href="/covid-19/" >
                    <span class="nav-label">COVID-19</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-867921" class="tncms-block add-padding"></div><div id="tncms-block-888080" class="tncms-block"><section id="block-888080" class="block emphasis-h3   " ><div class="block"><a href="https://www.southernminn.com/covid-19/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/c90b2454-6bab-11ea-8463-c37bd986caca.jpg?resize=200%2C17 200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/c90b2454-6bab-11ea-8463-c37bd986caca.jpg?resize=300%2C26 300w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/c90b2454-6bab-11ea-8463-c37bd986caca.jpg?resize=400%2C34 400w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/c90b2454-6bab-11ea-8463-c37bd986caca.jpg?resize=540%2C46 540w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/c90b2454-6bab-11ea-8463-c37bd986caca.jpg?resize=750%2C64 750w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/c90b2454-6bab-11ea-8463-c37bd986caca.jpg?resize=1200%2C103 1200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/c90b2454-6bab-11ea-8463-c37bd986caca.jpg 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-864710" class="tncms-block add-padding"></div><div id="tncms-block-864711" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864711" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864711');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-891911" class="tncms-block tnc-overlay"><div class="modal promo-designer-modal in centered " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true" >
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-891911" class="block emphasis-h3   " ><div class="promo-design"><div class="card-bg-color rounded_rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true" class="fas tnt-times"></span></button>
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline large light text-shadow">
                            Support local journalism
                        </div>
                    
                    
                        <p class="text light text-shadow">
                            Now, more than ever, the world needs trustworthy reporting—but good journalism isn’t free. Please support us by making a contribution.
                        </p>
                    <div class="promo-design-button">
                            <a href="/contribute">
                                <button type="button" class="btn btn-danger btn-lg">Contribute</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div></div></div>
        </div><article itemscope itemtype="https://schema.org/Article" id="asset-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="asset article-default"  data-url="https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/ccf30c42-2648-11e5-b4b0-afdfa9085526.jpg">
            <meta itemprop="width" content="1200">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="southernminn.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" />
    <style>
                .asset-paging .direction {
                    color: #a0cc39;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.southernminn.com\/tncms\/search\/mlt\/?origin=0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="asset-paging">
                <div id="paging-prev-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="paging-link prev offset"></div>
                <div id="paging-next-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Remembering Final Four that never was
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">By PAUL NEWBERRY
AP Sports Columnist
</span></li>
        
        
            <li class="visible-print">
        <time datetime="2020-04-03T17:42:00-05:00" class="tnt-date asset-date text-muted">
            Apr 3, 2020
        </time>
    </li>
            <li class="hidden-print">
        <time datetime="2020-04-03T17:42:00-05:00" class="tnt-date asset-date text-muted">58 min ago</time></li>
        
        
            <li class="hidden-print"><a href="/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html#comments" class="cm"><span class="fas tnt-comments"></span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-04-03T17:42:00-05:00">
    <meta itemprop="datePublished" content="2020-04-03T17:42:00-05:00">
    <meta itemprop="dateModified" content="2020-04-03T17:42:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Remembering%20Final%20Four%20that%20never%20was&url=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.southernminn.com/tncms/asset/editorial/0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSouthernminn%5D%20Remembering%20Final%20Four%20that%20never%20was&body=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" data-smart-adunit="/132916964/southernminn.com">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Remembering%20Final%20Four%20that%20never%20was&url=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.southernminn.com/tncms/asset/editorial/0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSouthernminn%5D%20Remembering%20Final%20Four%20that%20never%20was&body=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="save-list-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>ATLANTA (AP) — It would’ve been a magnificent weekend.</p><p>Hoops. Music. A confetti shower at the end.</p><p>A real celebration of basketball.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Heck, the persnickety spring weather in Atlanta even turned gorgeous Friday, as if it didn’t get the memo that there won’t be tens of thousands of out-of-town guests.</p><p>Birds chirping. Azaleas blooming. The temperature climbing into the 70s.</p><p>But this will always be remembered as the Final Four that never was, called off because of the coronavirus outbreak and one of the most sobering reminders of what this pandemic has cost the world of sports.</p><p>“Given today’s weather and the forecast for the weekend, it’s another gut punch to know what could’ve been,” rued Dan Corso, president of the Atlanta Sports Council.</p><p>The four teams would’ve been in Atlanta already, getting in their final practices at mammoth Mercedes-Benz Stadium in preparation for Saturday’s semifinal games — among the greatest days in sports, without question.</p><p>The 3-year-old, $1.5 billion stadium, a retractable-roof wonder normally used for football and soccer, would have undergone a hasty reconfiguration to essentially construct a new lower deck stretching all the way to courtside.</p><p>Those seats would’ve been filled with 80,000 fans.</p><p>It would’ve been electric.</p><p>“My son would have been a ball boy this weekend at the Final Four,” CBS Sports reporter Tracy Wolfson tweeted. ”Something he was of course really excited about. In honor, he dressed up today in his Final Four gear.” She added the hashtag: “missingthemadness.”“</p><p>Who knows which schools would’ve made it this far? If we go by the final poll from The Associated Press, Kansas, Gonzaga, Dayton and Florida State were the nation’s four best teams.</p><p>Ahh, Dayton.</p><p>Now that was a team we all could’ve embraced.</p><p>The Flyers were in the midst of a magical season, rolling into tournament play on a 20-game winning streak that had lifted spirits in a city battered in the past year by a mass shooting and devastating tornadoes.</p><p>Alas, we’ll never know if this was a team that missed out on its best chance to claim its first national title.</p><p>“The storm don’t last forever,” senior guard Trey Landers wrote early Friday on Twitter, no doubt mindful that he could’ve been in Atlanta this weekend. “Always remember that!”</p><p>Landers has moved on, signing with an agent in preparation for the NBA draft.</p><p>Dayton’s high-flying star, AP player of the year Obi Toppin, won’t be back next season either. He gave up his final two years of eligibility and will likely be one of the top picks in the draft.</p><p>For Dayton, the Final Four window has likely closed.</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>But we should make sure this special team will never be forgotten, even without a title on its resume.</p><p>“Although we feel like there was more for us to try to accomplish over the course of the season, there’s nothing that can take away what these young men did out on the court throughout the entire season,” coach Anthony Grant said.</p><p>While the Final Four was the star attraction, this weekend in Atlanta would’ve been so much more.</p><p>A series of free concerts were set to be held at Centennial Olympic Park, capped off by one of Taylor Swift’s few live performances in 2020.</p><p>On Sunday, the NCAA Division II and III title games were scheduled for State Farm Arena, sandwiched between the stadium and the park, adding to an already tantalizing lineup of hoops and tunes.</p><p>Now, nothing.</p><p>No buzzer-beating shots.</p><p>No dazzling dunks.</p><p>No disputed calls.</p><p>Not even a single shining moment.</p><p>“We put in a lot of lot of work the last two years,” Corso said Friday in a telephone interview. “Today, we were going to see it come to fruition.”</p><p>For Atlanta, this was supposed to be its fifth time hosting the Final Four. The city likely won’t get another shot until 2027, since the NCAA has already doled out its signature event for the next six years.</p><p>Out of fairness, the organization should seriously consider pushing everyone back a year, so the A-T-L can get a do-over in 2021.</p><p>But that doesn’t seem to be an option.</p><p>Instead, Corso said, the city is pushing to receive an automatic spot in the next round of Final Fours, which will cover the 2027-31 period. The bidding process begins next summer.</p><p>“We’ve had conversations with the NCAA about seeing if we can get in the next cycle without potentially going through the bid process,” he said. “Kind of an automatic bid.”</p><p>Of course, with the world coming to a standstill as it battles the deadly virus, sports is hardly the most pressing concern. But it will surely be a welcome salve when games are able to resume.</p><p>Unfortunately, there’s no getting back this Final Four.</p><p>It’s gone.</p><p>Forever.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Remembering%20Final%20Four%20that%20never%20was&url=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.southernminn.com/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.southernminn.com/tncms/asset/editorial/0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSouthernminn%5D%20Remembering%20Final%20Four%20that%20never%20was&body=https%3A%2F%2Fwww.southernminn.com%2Farticle_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/article_0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" class="save-list-0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("814eb089-f8b4-4f96-b70d-67e791b10427");
        var apiKey = "DKGDKQMXH5RJCHRBRDXD";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-814eb089-f8b4-4f96-b70d-67e791b10427';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div>

                    <div class="asset-comments hidden-print"><a id="comments-collapsible-toggle" class="btn btn-block btn-lg btn-default"><i class="fas tnt-sync"></i> Load comments</a><div id="comments-collapsible" class="comments-container-collapsible collapsed">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.southernminn.com/tncms/asset/editorial/0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div></div><div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.southernminn.com/tncms/search/mlt/?origin=0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    </div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-864713" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864713" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864713');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-864899" class="tncms-block"><section id="block-864899" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-864899 ">
        <div class="block-title-inner">
            <h3>
                
                Trending Now
                
            </h3>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular bold"><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/le_sueur_county_news/news/article_a686d2c7-0106-5cb2-8ef9-cfb0392ad0d6.html" class="tnt-asset-link">
        

        
            Le Sueur County has most confirmed COVID-19 cases in area</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/faribault_daily_news/news/local/article_9ecdda37-a190-5dec-bf30-d5cb38fa1a51.html" class="tnt-asset-link">
        

        
            Pastor among first southern Minnesotans with the coronavirus</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/owatonna_peoples_press/news/article_611f9e17-4288-5b21-9d81-34da0563ed90.html" class="tnt-asset-link">
        

        
            Friday fire displaces family of five</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/owatonna_peoples_press/news/article_74d64e6e-b469-5483-9f6a-1ccef22738ff.html" class="tnt-asset-link">
        

        
            Owatonna man killed Sunday in two-vehicle collision</a></h4>
                    
                </li><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/faribault_daily_news/news/article_4a562e5c-e471-558b-a73f-036556f045be.html" class="tnt-asset-link">
        

        
            Le Sueur County has most confirmed COVID-19 cases in area</a></h4>
                    
                </li></ul>
    </div>
    
</section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-864716" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864716" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864716');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-864714" class="tncms-block more-button"><section id="block-864714" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-864714 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="https://www.southernminn.com/calendar/faribault_daily_news/">
                
                Upcoming Events
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    
        <ul class="card event-list">
        
	        <li id="card-event-list-1f4f29fa-1b93-11ea-ab4b-e713f3394188" class="event-list-item  clearfix  tnt-section-calendar tnt-sub-section-lesueur-county-news">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Apr</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/lesueur_county_news/event_1f4f29fa-1b93-11ea-ab4b-e713f3394188.html" class="tnt-asset-link">
        

        
            Ring the Bell Fitness</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2020-04-03T05:00:00-05:00">
            Fri, Apr 3, 2020 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-a8367476-3ee2-11e6-96e4-d35d40c6839f" class="event-list-item  clearfix  tnt-section-calendar tnt-sub-section-outdoors">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Apr</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/outdoors/event_a8367476-3ee2-11e6-96e4-d35d40c6839f.html" class="tnt-asset-link">
        

        
            Closed AA</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2020-04-03T06:30:00-05:00">
            Fri, Apr 3, 2020 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-68140806-824e-11e9-884a-87f70ad6e6e1" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Apr</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/event_68140806-824e-11e9-884a-87f70ad6e6e1.html" class="tnt-asset-link">
        

        
            Exchange Club of Steele County</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2020-04-03T07:00:00-05:00">
            Fri, Apr 3, 2020 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-271bb822-3175-11ea-a9d7-2ba1e53af019" class="event-list-item  clearfix  tnt-section-calendar tnt-sub-section-st-peter-herald">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Apr</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/st_peter_herald/event_271bb822-3175-11ea-a9d7-2ba1e53af019.html" class="tnt-asset-link">
        

        
            Schaefer Fine Arts sophomore Minor Exhibition</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2020-04-03T08:00:00-05:00">
            Fri, Apr 3, 2020 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-53b7032c-b019-11e6-8c0c-ef5cfa83e95f" class="event-list-item last clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Apr</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/event_53b7032c-b019-11e6-8c0c-ef5cfa83e95f.html" class="tnt-asset-link">
        

        
            St. Vincent de Paul</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2020-04-03T09:00:00-05:00">
            Fri, Apr 3, 2020 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
        </ul>
    
        <ul class="list-inline block-links pos-bottom ">
            
                
                    <li><a href="/users/admin/calendar/events" class="">Submit an Event</a></li>
                
            
            
        </ul></section></div><div id="tncms-block-865046" class="tncms-block"><section id="block-865046" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-865046 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/legals">
                
                Public Notices
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-square border border-dotted"><li class="">
            <span class="tnt-headline ">
        
             <a href="http://www.southernminn.com/legals/" class="tnt-asset-link">
        

        
            City, Township, County and School District notices.</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="http://www.southernminn.com/classifieds/community/" class="tnt-asset-link">
        

        
            More Current Public Notices</a></span>
        </li></ul></div>
        </div></div></section></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-864719" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864719" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864719');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-865045" class="tncms-block"><section id="block-865045" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-865045 ">
        <div class="block-title-inner">
            <h3>
                
                Around the Web
                
            </h3>
        </div>
    </div></div>
    <div class=""><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/around_the_web/news/article_3f01a3df-caa3-53cc-a208-373f05b874b1.html" class="tnt-asset-link">
        

        
            Reynolds: Shelter at home issue needlessly dividing Iowans</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/around_the_web/sports/article_8f3445b0-265e-5f23-818d-7c9097ac1206.html" class="tnt-asset-link">
        

        
            SEC extends suspension of all in-person athletic activities</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/around_the_web/sports/article_0c97cf09-d35b-5f2c-8489-908edff29509.html" class="tnt-asset-link">
        

        
            SEC extends suspension of all in-person athletic activities</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/around_the_web/news/article_3bf0ef05-0e2c-57a4-9c00-8bc825b3dea3.html" class="tnt-asset-link">
        

        
            Reynolds: Shelter at home issue needlessly dividing Iowans</a></span>
        </li></ul></div></section></div><div id="tncms-block-865103" class="tncms-block"><section id="block-865103" class="block emphasis-h3   " ><div id="html-asset-865103">
            <div class="html-content"><div id="fbw_widget_container"></div>
<script defer type="text/javascript" src="https://marketplace.southernminn.com/places/fbwidget/"></script></div>
        </div></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div><div id="insticator-container" style="position:relative;margin-left:auto;margin-right:auto;width:300px;margin-bottom:40px;">
                    <div id="div-insticator-ad-1"></div>
                    <div id="insticator-embed"></div>
                    <div id="div-insticator-ad-2"></div>
                </div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"><div id="tncms-block-864687" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864687" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864687');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-864688" class="tncms-block padding-bottom footer-logo"><div id="site-logo-864688" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/f7d6b08c-4eaa-11ea-a39f-b7b58434d2e0.jpg?resize=200%2C106" 
            srcset="https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/f7d6b08c-4eaa-11ea-a39f-b7b58434d2e0.jpg?resize=200%2C106 200w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/f7d6b08c-4eaa-11ea-a39f-b7b58434d2e0.jpg?resize=300%2C160 300w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/f7d6b08c-4eaa-11ea-a39f-b7b58434d2e0.jpg?resize=400%2C213 400w, https://bloximages.newyork1.vip.townnews.com/southernminn.com/content/tncms/custom/image/f7d6b08c-4eaa-11ea-a39f-b7b58434d2e0.jpg 540w"
            sizes="(min-width: 1200px) 380px, 33.33vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-864691" class="tncms-block"><section id="block-864691" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-864691 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/eedition/" >
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link  tnt-section-online-features"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-864690" class="tncms-block"><section id="block-864690" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-864690 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-apg-media"  href="http://adamspg.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">APG Media</span>
                </a></li><li>
                <a class="nav-link  tnt-section-careers"  href="http://adamspg.com/careers/"  target="_blank" rel="noopener">
                    <span class="nav-label">Careers</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contest-rules"  href="/site/contest_rules.html" >
                    <span class="nav-label">Contest Rules</span>
                </a></li><li>
                <a class="nav-link  tnt-section-delivery-refund-policies"  href="/site/deliveryrefundpolicies.html" >
                    <span class="nav-label">Delivery / Refund policies </span>
                </a></li><li>
                <a class="nav-link  tnt-section-local-ads"  href="https://marketplace.southernminn.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Local Ads</span>
                </a></li><li>
                <a class="nav-link  tnt-section-privacy-policy"  href="/site/privacy.html" >
                    <span class="nav-label">Privacy Policy</span>
                </a></li><li>
                <a class="nav-link  tnt-section-terms-of-service"  href="/site/terms.html" >
                    <span class="nav-label">Terms of Service</span>
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                

    

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-864692" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-864692"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">Southernminn</a>, 514 Central Ave. Faribault, MN</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div><div id="tncms-block-864693" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864693" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864693');
                        
                });
            </script>
        </div>
    </div>
</div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-864731" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-864731" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-864731');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("0816e6c7-a51d-55d4-bfc4-b8b9b5bc619e")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.7db7c30ec731c03d1ae42ec7770ac1ed.js"></script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script>/*<![CDATA[*/ $("#comments-collapsible-toggle").click(function() { $("#comments-collapsible, #comments-collapsible-toggle").toggleClass("collapsed"); }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: '3.0', q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/b1ad8512-0208-404a-8bef-42066664235a.js');
                /*&lt;![CDATA[[*/Insticator.ad.loadAd('div-insticator-ad-1');Insticator.ad.loadAd('div-insticator-ad-2');Insticator.load('em',{id:'40c1ddd3-f53e-4cc2-99cf-8551b04a81fa'})/*]]&gt;*/ /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.1509acefe2ad7aac108313ac4c477d63.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/southernminn.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.401fb49843570310569f23fe61cfb144.js"></script>
<script>/*<![CDATA[*/ (function() {
                    window.addEventListener('load', function() {
                        __tnt.regions.stickySide.init(document.getElementById('sticky-right-rail'), document.getElementById('sticky-right-rail-spacer'), 'siderail', '.row');
                    });
                })(); /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script></body>
</html>